この記事は書きかけ中です。

いろいろなサイトからの引用で作ってあります。

数値解析ライブラリで、有名になってきている。

Windows cygwin環境でがんばってみるときのメモ
Windows cygwin環境でがんばってみたが、うまくいかないことがわかるメモ

macかlinuxでやるとよさそう。

windowsの場合は、cygwinでは、whlファイルがcygwinに対応していないとかで入らない。

*Windowsはwheelをつかえ [#v9f12773]

pip と wheel を windows でも使いこなす

http://qiita.com/toruuetani/items/b0000e9f5c89a350d4f8#2-2


**本家URL [#m5d15f68]

http://pandas.pydata.org/

本家のサイトをみると、一番いいインストール方法は、conda
を使えと書いてある

 conda install pandas

**後で知ったのですが、Minicondaというpython + condaインストーラがある模様 [#yfba30b2]
http://conda.pydata.org/miniconda.html

***Python Conda Tips [#l5abfa59]
Pythonの実行環境であるMinicondaのコマンドTips。

http://qiita.com/icoxfog417/items/02a80b93b5f1e95f2795

***手元のpythonのバージョンを確認してみる。 [#k3b106a4]

 python -V

結果

Python 2.7.12

*インストーラ pip のインストール [#yfe03f75]

pipが使えるようになっていないと、インストールができないようです。

cygwinからは、cygwinのインストーラからpython-setuptoolsを
選んで、


OK
 easy_install pip

ためしに、condaも入るかな?

OK 

 easy_install conda


じゃあ
 conda install pandas
できるかな?

結果
 Traceback (most recent call last):

 (略)

 ImportError: No module named enum


これはpython3のライブラリのことで、
 pip install enum34
とやることで、回避できるようです。


いろいろ、インストールいるんじゃない?

cygwinで入れるべきものは、easy_installは面倒みてくれないのかもしれない。


***メモ [#s0196ff0]
easy_installがないといわれても、
easy_install (Tabキー)でバージョンがでるので、それを使うようです。

***エラー [#le6825e2]
ミスした例
 easy_install install pip

No local packages or download links found for install

error: Could not find suitable distribution for Requirement.parse('install')

*wheelを入れる [#w8b4d315]
https://pypi.python.org/pypi/wheel/#downloads

wheel-xx.tar.gzを落として、cmdから以下を打つ。

 pip install (wheel-0.xx.0.tar.gzの絶対パス)

**wheelファイルでインストール [#ue5ea22d]
numpy,  pandasのwhlファイルを取得する。ついでにscipyやipythonも

 http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy
 http://www.lfd.uci.edu/~gohlke/pythonlibs/#pandas
 http://www.lfd.uci.edu/~gohlke/pythonlibs/#scipy

cmdから以下を打つ
 pip install  (whlファイルの絶対パス)

pandasの前にnumpyを読み込んでおくこと。
トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS